How to install Virtualbox on Ubuntu 16 Xenial

How to install Virtualbox on Ubuntu 16 Xenial

Howto install Virtualbox On Fedora 18

Virtualbox is one of popular Virtual Machines System in the world. In this guide, we will guide you how to do installation on Ubuntu 16.

Step 1: Add repository

root@ubuntu:~# sudo add-apt-repository “deb http://download.virtualbox.org/virtualbox/debian trusty contrib”

Step 2: Install Virtualbox

root@ubuntu:~# sudo apt-get update; sudo apt-get install virtualbox
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable Release
Get:3 http://download.virtualbox.org/virtualbox/debian trusty InRelease [7,152 B]
Ign:5 http://linux.dropbox.com/ubuntu precise InRelease
Ign:3 http://download.virtualbox.org/virtualbox/debian trusty InRelease
Hit:6 http://download.virtualbox.org/virtualbox/debian trusty/contrib amd64 Packages
Ign:6 http://download.virtualbox.org/virtualbox/debian trusty/contrib amd64 Packages
Hit:7 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:8 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Hit:9 http://download.virtualbox.org/virtualbox/debian trusty/contrib i386 Packages
Ign:9 http://download.virtualbox.org/virtualbox/debian trusty/contrib i386 Packages
Hit:10 http://linux.dropbox.com/ubuntu precise Release
Hit:11 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu xenial InRelease
Hit:6 http://download.virtualbox.org/virtualbox/debian trusty/contrib amd64 Packages
Hit:12 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:9 http://download.virtualbox.org/virtualbox/debian trusty/contrib i386 Packages
Hit:13 http://repository.spotify.com stable InRelease
Hit:14 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
Fetched 7,152 B in 1s (3,594 B/s)
Reading package lists… Done

Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
dkms libgsoap8 libqt4-dbus libqt4-declarative libqt4-network libqt4-opengl libqt4-script libqt4-sql libqt4-sql-sqlite libqt4-xml libqt4-xmlpatterns libqtcore4 libqtdbus4 libqtgui4 libvncserver1
qdbus virtualbox-dkms virtualbox-qt
Suggested packages:
libqt4-declarative-folderlistmodel libqt4-declarative-gestures libqt4-declarative-particles libqt4-declarative-shaders qt4-qmlviewer libqt4-dev qt4-qtconfig vde2 virtualbox-guest-additions-iso
The following NEW packages will be installed:
dkms libgsoap8 libqt4-opengl libvncserver1 virtualbox virtualbox-dkms virtualbox-qt
The following packages will be upgraded:
libqt4-dbus libqt4-declarative libqt4-network libqt4-script libqt4-sql libqt4-sql-sqlite libqt4-xml libqt4-xmlpatterns libqtcore4 libqtdbus4 libqtgui4 qdbus
12 upgraded, 7 newly installed, 0 to remove and 308 not upgraded.
Need to get 32.3 MB of archives.
After this operation, 96.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 dkms all 2.2.0.3-2ubuntu11 [67.4 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 libgsoap8 amd64 2.8.28-1 [216 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqtgui4 amd64 4:4.8.7+dfsg-5ubuntu2 [4,109 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqt4-declarative amd64 4:4.8.7+dfsg-5ubuntu2 [1,090 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqt4-script amd64 4:4.8.7+dfsg-5ubuntu2 [814 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqt4-xmlpatterns amd64 4:4.8.7+dfsg-5ubuntu2 [1,091 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqt4-network amd64 4:4.8.7+dfsg-5ubuntu2 [561 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqtdbus4 amd64 4:4.8.7+dfsg-5ubuntu2 [186 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqt4-dbus amd64 4:4.8.7+dfsg-5ubuntu2 [6,436 B]
Get:10 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 qdbus amd64 4:4.8.7+dfsg-5ubuntu2 [29.9 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqt4-xml amd64 4:4.8.7+dfsg-5ubuntu2 [96.3 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqt4-sql-sqlite amd64 4:4.8.7+dfsg-5ubuntu2 [23.5 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqt4-sql amd64 4:4.8.7+dfsg-5ubuntu2 [98.6 kB]
Get:14 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqtcore4 amd64 4:4.8.7+dfsg-5ubuntu2 [1,552 kB]
Get:15 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libqt4-opengl amd64 4:4.8.7+dfsg-5ubuntu2 [301 kB]
Get:16 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 libvncserver1 amd64 0.9.10+dfsg-3build1 [121 kB]
Get:17 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 virtualbox-dkms all 5.0.16-dfsg-2 [616 kB]
Get:18 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 virtualbox amd64 5.0.16-dfsg-2 [14.1 MB]
Get:19 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 virtualbox-qt amd64 5.0.16-dfsg-2 [7,170 kB]
Fetched 32.3 MB in 33s (959 kB/s)
Preconfiguring packages …
Selecting previously unselected package dkms.
(Reading database … 185960 files and directories currently installed.)
Preparing to unpack …/dkms_2.2.0.3-2ubuntu11_all.deb …
Unpacking dkms (2.2.0.3-2ubuntu11) …
Selecting previously unselected package libgsoap8:amd64.
Preparing to unpack …/libgsoap8_2.8.28-1_amd64.deb …
Unpacking libgsoap8:amd64 (2.8.28-1) …
Preparing to unpack …/libqtgui4_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqtgui4:amd64 (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Preparing to unpack …/libqt4-declarative_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqt4-declarative:amd64 (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Preparing to unpack …/libqt4-script_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqt4-script:amd64 (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Preparing to unpack …/libqt4-xmlpatterns_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqt4-xmlpatterns:amd64 (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Preparing to unpack …/libqt4-network_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqt4-network:amd64 (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Preparing to unpack …/libqtdbus4_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqtdbus4:amd64 (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Preparing to unpack …/libqt4-dbus_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqt4-dbus:amd64 (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Preparing to unpack …/qdbus_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking qdbus (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Preparing to unpack …/libqt4-xml_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqt4-xml:amd64 (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Preparing to unpack …/libqt4-sql-sqlite_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqt4-sql-sqlite:amd64 (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Preparing to unpack …/libqt4-sql_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqt4-sql:amd64 (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Preparing to unpack …/libqtcore4_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqtcore4:amd64 (4:4.8.7+dfsg-5ubuntu2) over (4:4.8.7+dfsg-5ubuntu1) …
Selecting previously unselected package libqt4-opengl:amd64.
Preparing to unpack …/libqt4-opengl_4%3a4.8.7+dfsg-5ubuntu2_amd64.deb …
Unpacking libqt4-opengl:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Selecting previously unselected package libvncserver1:amd64.
Preparing to unpack …/libvncserver1_0.9.10+dfsg-3build1_amd64.deb …
Unpacking libvncserver1:amd64 (0.9.10+dfsg-3build1) …
Selecting previously unselected package virtualbox-dkms.
Preparing to unpack …/virtualbox-dkms_5.0.16-dfsg-2_all.deb …
Unpacking virtualbox-dkms (5.0.16-dfsg-2) …
Selecting previously unselected package virtualbox.
Preparing to unpack …/virtualbox_5.0.16-dfsg-2_amd64.deb …
Unpacking virtualbox (5.0.16-dfsg-2) …
Selecting previously unselected package virtualbox-qt.
Preparing to unpack …/virtualbox-qt_5.0.16-dfsg-2_amd64.deb …
Unpacking virtualbox-qt (5.0.16-dfsg-2) …
Processing triggers for man-db (2.7.5-1) …
Processing triggers for libc-bin (2.23-0ubuntu2) …
Processing triggers for systemd (229-3ubuntu2) …
Processing triggers for ureadahead (0.100.0-19) …
Processing triggers for shared-mime-info (1.5-2) …
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) …
Processing triggers for gnome-menus (3.13.3-6ubuntu3) …
Processing triggers for desktop-file-utils (0.22-1ubuntu4) …
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160321-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for mime-support (3.59ubuntu1) …
Setting up dkms (2.2.0.3-2ubuntu11) …
Setting up libgsoap8:amd64 (2.8.28-1) …
Setting up libqtcore4:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up libqt4-xml:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up libqtdbus4:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up libqt4-network:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up libqt4-script:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up libqt4-sql:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up libqt4-xmlpatterns:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up qdbus (4:4.8.7+dfsg-5ubuntu2) …
Setting up libqt4-dbus:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up libqt4-sql-sqlite:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up libvncserver1:amd64 (0.9.10+dfsg-3build1) …
Setting up virtualbox-dkms (5.0.16-dfsg-2) …
Loading new virtualbox-5.0.16 DKMS files…
First Installation: checking all kernels…
Building only for 4.4.0-15-generic
Building initial module for 4.4.0-15-generic
Done.

vboxdrv:
Running module version sanity check.
– Original module
– No original module exists within this kernel
– Installation
– Installing to /lib/modules/4.4.0-15-generic/updates/dkms/

vboxnetadp.ko:
Running module version sanity check.
– Original module
– No original module exists within this kernel
– Installation
– Installing to /lib/modules/4.4.0-15-generic/updates/dkms/

vboxnetflt.ko:
Running module version sanity check.
– Original module
– No original module exists within this kernel
– Installation
– Installing to /lib/modules/4.4.0-15-generic/updates/dkms/

vboxpci.ko:
Running module version sanity check.
– Original module
– No original module exists within this kernel
– Installation
– Installing to /lib/modules/4.4.0-15-generic/updates/dkms/

depmod…….

DKMS: install completed.
Setting up virtualbox (5.0.16-dfsg-2) …
vboxweb.service is a disabled or a static unit, not starting it.
Setting up libqt4-declarative:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up libqtgui4:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up libqt4-opengl:amd64 (4:4.8.7+dfsg-5ubuntu2) …
Setting up virtualbox-qt (5.0.16-dfsg-2) …
Processing triggers for libc-bin (2.23-0ubuntu2) …
Processing triggers for systemd (229-3ubuntu2) …
Processing triggers for ureadahead (0.100.0-19) …
You have new mail in /var/mail/root
root@ubuntu:~#

Step 3: Start Virtualbox

ubuntu16_virtualbox

Leave a reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>