Howto install ionCube PHP Loader v4.2.1 on PHP 5.4

Howto install ionCube PHP Loader v4.2.1 on PHP 5.4

 

1. Use rightscale repo for PHP 5.4

[root@localhost yum.repos.d]# vi /etc/yum.repos.d/rightscale-epel.repo

[rightscale-epel]

name = none

baseurl = http://cf-mirror.rightscale.com/rightscale_software/epel/6/x86_64/archive/20120918

http://ec2-eu-west-mirror1.rightscale.com/rightscale_software/epel/6/x86_64/archive/20120918

http://ec2-us-east-mirror.rightscale.com/rightscale_software/epel/6/x86_64/archive/20120918

http://ec2-us-east-mirror1.rightscale.com/rightscale_software/epel/6/x86_64/archive/20120918

http://ec2-us-east-mirror2.rightscale.com/rightscale_software/epel/6/x86_64/archive/20120918failovermethod=priority

gpgcheck=0

enabled=1

gpgkey=

# set metadata to expire faster then main

metadata_expire=30

2. Install ionCube PHP Loader v4.2.1 on PHP 5.4

[root@localhost yum.repos.d]# yum install php54-ioncube-loader

Loaded plugins: fastestmirror, refresh-packagekit, security

Loading mirror speeds from cached hostfile

* base: mirrors.digipower.vn

* epel: ftp.jaist.ac.jp

* extras: mirrors.digipower.vn

* rightscale-epel: ec2-eu-west-mirror1.rightscale.com

* updates: mirrors.digipower.vn

rightscale-epel | 1.3 kB 00:00

Setting up Install Process

Resolving Dependencies

–> Running transaction check

—> Package php54-ioncube-loader.x86_64 0:4.2.1-1.ius.el6 will be installed

–> Finished Dependency ResolutionDependencies Resolved=====================================================================================================================================================================================================

Package Arch Version Repository Size

=====================================================================================================================================================================================================

Installing:

php54-ioncube-loader x86_64 4.2.1-1.ius.el6 rightscale-epel 596 kTransaction Summary

=====================================================================================================================================================================================================

Install 1 Package(s)

Total download size: 596 k

Installed size: 2.2 M

Is this ok [y/N]: y

Downloading Packages:

php54-ioncube-loader-4.2.1-1.ius.el6.x86_64.rpm | 596 kB 00:40

Running rpm_check_debug

Running Transaction Test

Transaction Test Succeeded

Running Transaction

Installing : php54-ioncube-loader-4.2.1-1.ius.el6.x86_64 1/1

Verifying : php54-ioncube-loader-4.2.1-1.ius.el6.x86_64 1/1

Installed:

php54-ioncube-loader.x86_64 0:4.2.1-1.ius.el6

Complete!

[root@localhost yum.repos.d]#

3. Check PHP loader on PHP

[root@localhost yum.repos.d]# php -v

PHP 5.4.4 (cli) (built: Jun 14 2012 17:30:51)

Copyright (c) 1997-2012 The PHP Group

Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies

with the ionCube PHP Loader v4.2.1, Copyright (c) 2002-2012, by ionCube Ltd., and

with Xdebug v2.2.0, Copyright (c) 2002-2012, by Derick Rethans

[root@localhost yum.repos.d]#

That’s all. Thanks for using IThelpblog.com.

Tags:  

Leave a reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>